Why won't my filter suggestions populate? (Prior to 3.48)

#1

Note that as of Looker 3.48, access_filter_fields and sql_always_where will not prevent suggestions from populating. full_suggestions: true will be applied to all fields that are exposed by an explore that uses access_filter_fields or sql_always_where parameters. For more information, see the full_suggestions documentation.
The following applies to pre-3.48 Looker versions.

You may have a field that should be populating suggestions when you add it as a filter in Explore. In most situations, string filters will suggest possible values by default. Read more about how suggestions are populated here.

However, if you have access_filter_fields or sql_always_where defined on an explore, fields in that explore will not automatically provide suggestions when filtered. This is because auto-suggestions for dimensions are disabled in explores that use access_filter-fields or sql_always_where to prevent users from seeing any values they should not be seeing. Both normal explore filters and dashboard filters of type field_filter are impacted.

If you would like to enable suggestions for explores with access_filter-fields or sql_always_where, read about the full_suggestions parameter here.

0 Likes

(Ken Cunanan) #2

It may be useful to know that dimension field that’s of a type: number will also not populate suggestions. If you’d like to populate those fields, the best way would be to convert those fields to type: string.

0 Likes

(Elan Weiner) #3

For Looker versions 3.40 and greater, when the generator is run for a Hadoop dialect, including Impala, it will add “suggestions: false” to each view that is created by default. This was based on feedback from customers that didn’t want Looker running a bunch of SELECT DISTINCT suggestions for every filtered field. If you comment that out, it will enable the suggestions again.

0 Likes