Looker Community

Table bar charts scaling

I can’t understand why 928 is suddenly barely visible… is it because they’re the lowest numbers (926, 927, 928)?

image

Somehow it just looks odd like that.

A choice of selecting minimum as 0 or as lowest number would be champion :smiley:

2 Likes

+1

We noticed this the other day when we were looking at something, but couldn’t see an option to show the bar in context.

+1

Same happening with stacked bar charts. Small values are not shown

This has come up a few different times, in different posts – basically, right now, the smallest value in the column automatically becomes the “no-length” bar.

There have been a lot of requests to be able to force a “0”-axis, but that’s just a pending feature request, for now.

For the Looker perspective— We initially evaluated this as a bug, but it was determined to be expected behavior and the bars are supposed to span from min value to max value, rather than 0 to max.

So, this is being treated as a feature request instead! Other folks have also mentioned being interested in setting arbitrary max/min values, not just pegging it to 0.

Hi @izzy bumping up this one as this really limits the use of bars in tables (which are a great way of visualising relative ratios).

For example, in this example we want the bars to represent a percentage, but without the option to scale from 0, the bars are really missleading - 0.4 should be 40% but instead it looks hardly visible…

Looker

1 Like

Personally I would categorise as a bug and not a feature request as it produces content that’s miss-leading. One of our clients expressed this yesterday and it’s hard to argue the point that this is expected behaviour!

2 Likes

A hack we are having to use is to spoof a 0 value in the table… At least makes the bars now show the correct data.

Hope it helps others!

Thanks for the feedback and double thanks for the workaround/hack. All the feedback posted here is getting relayed to the appropriate channels.

Just FYI, we’re still considering this one a feature request, so it’s not being specifically prioritized for completion. I’ll update here if we make plans to address it.

Throwing in my support for this one as well! While the workaround of introducing a “zeroing” row works it isn’t very aesthetically pleasing.