Some of my dashboards don't have a 'run' button at the top

Some of my dashboards don’t have a run button at the top, does anyone know why? Or how i can get the run button back?

This happens when the dashboard is set to Run on Load and there are not any dashboard level filters. To get the run button back you can head into the dashboard settings and toggle off the Run on Load option.

1 Like