Markdown navigation not compatible with IDE folders

Noticed that the navigation will not work with the new folder set up in IDE (https://docs.looker.com/data-modeling/getting-started/ide-folders, https://docs.looker.com/data-modeling/getting-started/other-project-files). Even when its in the same folder is uses “%2F” instead of “/” in the url which causes an error

1 Like

Hey Kyle, sorry I never updated on this.

The bug has been reproduced + filed with our engineering team, any updates will be posted here.

Thanks much for reporting! Entomologist badge granted :sparkles:

1 Like

We just patched this up, the fix will be present in the next Looker release (6.20). Thanks again for reporting!

1 Like

Does not seem to have been fixed in release 6.20, I still have “document not found” on all my navigation links. Any update there?

Can you share the URL that it’s attempting to bring you to? As far as I’m aware, this should be present in 6.20 but perhaps you’re running into a slightly different case.

Sure thing:

https://[domain].looker.com/projects/[project]/documents/Documentation%2F05_release_notes.md

05_release_notes.md being the document name

We’ve reopened this bug internally and are working on re-fixing it. It looks like there may be another case that wasn’t covered initially. Thanks for reporting, will update when it’s fixed again— Hopefully for good!

We’ve just pushed the full fix for this— Once your instances are next updated you’ll see the intended functionality start working again. Thanks for reporting!

1 Like

Thanks @izzy!!!