Legend not displayed when exporting Dashboard in PDF

Hey, since a few days when I’m exporting a dashboard in .pdf the legend is not showing.

Any idea why ?

Thanks

Hi @macbilouty,

This is a known issue at the moment.

We are releasing shortly a new rendering platform that will address this issue completely, but in the meanwhile you can turn off Enhanced Visualizations as a workaround.

Best,

Hi - I’m seeing this right now in our deployed version, 5.20.7 - when is this expected to be fixed?

Edited - to clarify, we are seeing the symbols for the legend, but the labels associated with the symbols are completely missing, so it just looks like a series of colored circles… this is with either single-column PDF or the regular PDF export, and it appears to be a problem for both bar graphs and line graphs.

Hey @apsmith,

We’re expecting the new rendering platform to be available around the end of the quarter. In the meantime, turning off Enhanced Visualizations should allow the legends to show up correctly in your visualizations.

Would you mind defining your quarter so we have better expectations?

Thanks, I wasn’t sure what you meant, but I did find an admin setting for “Enhanced Visualizations” and turned that off which seems to have helped - what effect does this have other than to fix this bug?

Hey @Ipear3 and @apsmith,

Q3 ends on the last day of September, but it actually turns out that the new rendering engine will be available in the next release, which will be rolling out over the next four weeks. The Enhanced Visualizations feature is mostly an architectural change, so you won’t currently see any major changes when it is turned on. Together with the new renderer, it will allow us to release more new features for visualizations in the future. Keep in mind that like Enhanced Visualizations, the new renderer will be a Beta Labs feature, and as such will continue to be under active development after it is released.

1 Like

This issue appears not only to affect legends, but certain crucial axis labels as well. It made a scheduled email report totally meaningless, see below screenshot (not cropped)

Hi Paul_Schaffer,

Try please disabling Enhanced Visualizations from Labs/Experimental menu under Admin. Then try to download/schedule the email again as PDF or PNG.

Let me know if that helps.

We’re moving to a new renderer soon, that might solve all/ the major part of those issues.

Best,

Having this issue now - is disabling Enhanced Visualizations still the recommended workaround to get legends to display when exporting to PDF?

What version are you on?

Legacy visualizations have been deprecated since Looker 6.0, I believe. If you’re on a later version and running into this, you should reach out to support at help.looker.com and pass over all the info you’ve got.