Legacy Feature Notice: Allow Calling Legacy Query API


(Tig Newman) #1

In September, 2016, Looker rolled out a newer API and its docs, while deprecating the older Legacy API.

The newer API is a secure, “RESTful” application programming interface for managing your Looker instance, and fetching data through the Looker data platform. With the Looker API you can write applications or automation scripts to provision new Looker user accounts, run queries, schedule reports, etc. Just about anything you can do in the Looker application you can do via the Looker API.

If you are still using the older legacy API, Starting in Looker 5.2, there is a legacy feature that permits the use of the older legacy API calls.

This feature lets you check whether you are using the older API and block use of that API when you are ready. In Looker 5.2 and 5.4, this feature is turned ON by default and in later releases it will be OFF by default and eventually removed as listed in the End of Life Schedule.

Due to its many benefits, Looker will eventually require all customers to use the new API. Therefore, we encourage any customers still using the older API to transition as soon as possible.


Looker 5.2 Release Notes
Looker 5.2 Extended Support Release Notes