Excluding the first row in a table of time series data


(Ben) #1

Hi all,

I have a table of time series data tracking visits to a website, I have added calculated fields to track the standard deviation in variance between visits today and expected visits, in order to flag outliers in the data.

This is working well, but I have an issue where my most recent row (the most recent 5 minutes), is often flagged as an outlier due to having incomplete data. I’d like to exclude the most recent row from my data, however in my current setup I am only showing the most recent row in my visualization, which is the yes/no outlier indicator that my email schedule is based on.

Can anyone suggest a way I can hide the most recent row? As you can see I’ve tried adding a calculated field to highlight it, but due to this being a calculated field I can’t filter out the row.

Ben


(Tom Russell) #2

40%20PM You can limit the displayed rows to hide the first or last N rows.


(Ben) #3

Hi @Tom.Russell

Thanks for your response - I am aware of this, but what I really need is to hide first AND last. My requirement is to only show one row, but for this to be the second row, not the first, which cannot be achieved with the setting above?

Ben


(Sara Guzman) #4

Hi @Ben

You can do this by creating a table calculation that only returns Yes for the rows you want to see in the visualization, and then using Hiding No’s from Visualization for that table calculation. Using row() this function, as shown in this Discourse - How to limit a visualization using table calculations.

Let us know if you have any more questions on this.

Best,
Sara


(Ben) #5

Aha, perfect, thanks Sara!