Data points missing

on-hold
low_priority
file
(Dawid) #1

I produced a look that has probably about 2500 data points on a time series. I removed the 500 row limit and when I run the look everything is shown correctly. Then I save it and go to my dashboard and for some reason I can only see 500 data points. Anything I should change to get all the data?

0 Likes

(Izzy) #2

Could it be a caching problem? ie: have you cleared cache + refreshed the dashboard?

Barring that, could your visualization settings be set to “Show the first 500 rows” and in the Look, you’re looking at the “results” section instead of the table visualization?

0 Likes

(Dawid) #3

Visualisation has no limit of displayed rows, same with results section. The look itself shows everything but the dashboard doesn’t (not sure if it’s 500 data points, probably about 900)

0 Likes

(Izzy) #4

So interesting. I can’t seem to replicate this, have you tried just starting from scratch with a new Tile? Or with a new Look? I’d be interested to know if it happens consistently or if it’s only this one look, or even look/dashboard combo.

0 Likes

(Dawid) #5

It’s a completely new tile. Have you tried replicating it having at least 3000 data points in the table?

0 Likes

(Izzy) #6

I tried it with 5000, and it seemed to work alright.

This sounds weird, but could you try dragging the tile smaller on the dashboard and re-running and let me know what you see?

0 Likes

(Dawid) #8

That didn’t do anything unfortunately.

I also tried to set Limit displayed rows on visualisation to 5000 but that didn’t help either

0 Likes

(Izzy) #9

I guess I’ll go back to my earlier question then of if this is happening to every tile/dashboard, or if it’s specific to one dashboard— Or even one tile on the dashboard. Is there anything unusual about the tile? A Merged Result, does it have table calcs, etc. etc.

0 Likes

(Dawid) #10

Oh no, this was a very simple tile with one dimension (date) and one metric (number of sessions). No gimmicks at all. Changed the row limit to 0 and all data points showed (7 years of data) in the explore. Saved it, put it in a dashboard, only 1.5 years show up

–edit

I added completely fresh tile and the problem persists. Then I created a new dashboard and added a new tile and still the same :frowning:

0 Likes

(Izzy) #11

I’m seeing some interesting behavior with the 0 row limit on my end, though not limiting down to 500. Have you tried inputting 5000 instead? When I enter 0, I get 5000 in the explore but 1000 on the dashboard, but when I put 5000 I get the full amount.

Seems like even though the numbers are different between us, it could be the same thing.

0 Likes

(Dawid) #12

Wow, I tried that before and didn’t work but now it did… I guess 0 for the Data tab means ALL but for the dashboard it means DEFAULT (500 or 1500 or something)

0 Likes

(Izzy) #13

Glad it worked! That is interesting, and I don’t see it documented anywhere. I’ll make sure that it a.gets documented or b. we change the behavior to be more consistent.

0 Likes

(Reed R Rawlings) #15

For anyone else, an alternate workaround I found for this issue was entering a row limit of 4999 which then enabled me to hardcode a row limit of 5,000 for a heat map visualization.

0 Likes