Dashboard filter showing white space where no data available

done
low_priority
reply

(Paul Wadsworth) #1

I have a dashboard set up to show data since the 1st of August. This applies to all of the views in the dashboard.
One of the views only has data from the 1st of October, this means there is 2 months of white space in the graph I’d rather not have. Similarly, I’ve been asked to only show data from the 1st of January this year.
Is there a way I can keep the dashboard filter applicable to that view, so if a user changes it to “The last 2 weeks” or similar it will affect that view. Or do I need to unlink that filter from the view to make sure the graph only starts on the 1st of October/January?


(My Lux Home) #2

The best way is to basically filter it out or you can have missing value filled out by a default number you want to show - so it doesn’t have white space and is based on your average number. It really depends on what you’re trying to do.


(Paul Wadsworth) #3

Views 1 and 2 are pointing at a model with data for 2+ years. But for the dashboard, we’re only interested in data from the 1st of August 2018.
View 3 is pointing at a different model that only has data from the 1st of October.

Because we only want data from the 1st of August 2018, I have a filter on the dashboard with that, and all the tiles in the dashboard are using that filter. It looks like I have several options:

  1. Have view 3 linked to the same filter, and it show 0s between 1st August and 1st of October, simply because the data is not there.
  2. Have view 3 unlinked from the dashboard filter, but if a user changes the dashboard filter to “Last 2 weeks” view 3 won’t change at all.

I’m hoping for some sort of 3rd option, where the view thinks “Oh, the Dashboard filter wants information from August, but the View filter says only to use from October, so the Chart will start in October, not August”.

I first hoped that adding filters to the view would fix the issue, but if I put a filter in the view saying only to get data from the 1st of January 2019 (for example) then the graph updates to only show data from the 1st of January, but the bottom axis is still showing from August, and just saying everything is 0 until the 1st of January