Dashboard filter not applying correctly on the scheduled PDF Export

done
normal_priority
reply

#1

Hi All,

I tried searching for this issue, but it appears that this isn’t a widespread issue. We have a dashboard that has 10 Look tiles. Those Look tiles are built at a high level (QTD), then we apply dashboard date filters to get the proper segmentation and send it out to the appropriate teams (for now, the request is past 28 days, but from my experience this is likely to change soon - so we use dashboard filters to make updating faster instead of going into each individual tile and updating the filters there).

Lately, we noticed that the date filter defaults to “past 7 days” instead of the “past 28 days” that we originally put in the dashboard. When I go into the link where we have the dashboard scheduled, the dashboard is applying the correct “past 28 days” filter.

Does anyone know why when the scheduled PDF export is sent out, the dashboard date filter reverts to the default “past 7 days”?

Thanks,


(Elliot Park) #2

Hey @JLiou,

Thanks for writing! One thing that could be happening here is that the filter value on the schedule itself could be set to “past 7 days”. Can you confirm what the filter value is set to on the scheduler modal?

Elliot


#3

Hello,

Yes, the schedule filter has the correct date filter with the “past 28 days” but when the PDF is exported from the schedule it continues to apply the “pasts 7 days” filter.

One of the reports fixed itself (the following day - without anyone making any changes - the report showed the proper “past 28 days” filter applied). Any idea why this is happening?

We have to manually re-distribute with the correct date filter after the scheduled export for some of our reports, which is causing some confusion.

Thanks,


(John Robinson) #4

I am having similar problems. Tiles are not inheriting global filter props from dashboard.


(Izzy) #5

@JRobinson Are you seeing the same behavior as the previous posters where the filters aren’t applied properly to the PDF export? Or is it happening on the actual in-Looker dashboard as well?