Configure New Relic APM for Looker

admin

#1

I have tried downloading Java APM agent and configured to run with looker jar file. However the looker application didn’t start after configuring newrelic.

As suggested here I have tried passing newrelic jar file path as java argument

https://docs.newrelic.com/docs/agents/java-agent/installation/install-java-agent#h2-install-agent

Got below error in looker.log when I start Looker:

2018-11-02 18:43:59.219 +0000 [WARN|007d0|ruby:stderr] :: NotImplementedError: getppid unsupported or native support failed to load; see http://wiki.jruby.org/Native-Libraries 
ppid at org/jruby/RubyProcess.java:1114 
ppid at org/jruby/RubyProcess.java:1111 
<class:SystemUniversal> at uri:classloader:/gems/systemu-2.6.5/lib/systemu.rb:28 
<main> at uri:classloader:/gems/systemu-2.6.5/lib/systemu.rb:13 
require at org/jruby/RubyKernel.java:955 
<main> at uri:classloader:/helltool-component-build/lib/helltool/initializers/001_requires.class:1 
load at org/jruby/RubyKernel.java:973 
<main> at uri:classloader:/helltool-component-build/lib/helltool/initializers/001_requires.class:20 
require at org/jruby/RubyKernel.java:955 
block in (root) at uri:classloader:/helltool-component-build/lib/helltool/initializers/001_requires.rb:1 
each at org/jruby/RubyArray.java:1734 
(root) at uri:classloader:/helltool-component-build/lib/helltool/initializers/001_requires.rb:1 
(root) at uri:classloader:/helltool-component-build/lib/helltool/runner.class:1 
start at uri:classloader:/helltool-component-build/lib/helltool/runner.class:7 
start at uri:classloader:/helltool-component-build/lib/helltool/runner.class:7 
start at uri:classloader:/helltool-component-build/lib/helltool/cli.class:65 
run at uri:classloader:/gems/thor-0.15.4/lib/thor/task.rb:27 
<main> at uri:classloader:/gems/thor-0.15.4/lib/thor/invocation.rb:120 
load at org/jruby/RubyKernel.java:973 
<main> at uri:classloader:/gems/thor-0.15.4/lib/thor.rb:275 
require at org/jruby/RubyKernel.java:955 
start at uri:classloader:/gems/thor-0.15.4/lib/thor/base.rb:425 
<main> at uri:classloader:/helltool-component-build/bin/helltool:29

Appreciate any help in setting up APM agent on Looker.

Thanks


(Peggy Beard) #2

Hi @ypineni ! Reading a bit online here, it seems that this may be related to libcrypt.so .

If the steps in the article don’t resolve the issue, then we’ll need to gather some more information from you in order to help you get this set up. Please reach out to us at support@looker.com and we’ll help you resolve it!