Chart Element Layering / Priority


#1

Would appreciate the ability to set the display level of chart series elements. Either that, or have charts automatically render a line series on top of a bar series, rather than visa versa, as I’m experiencing with the below chart:


#2

Update: apparently changing the relative order of the columns in the “results” layer fixes this issue. Glad I was able to resolve the issue, but this control really should live in the series menu.


#3

+1 on this

What’s the use case for burying the line behind the columns? This creates an issue when I want my primary metric and first series in the chart legend to be the columns and the secondary metric to be the line, which I want to appear on top of the columns.

I can either have:

  • Primary metric as first series in legend but line gets buried behind column
  • Secondary metric as first series (not ideal) and line correctly on top of the columns

I can’t get the primary metric to be the first series in the legend and the line to appear on top of the column.

Thanks,
Tim


(Scott Vickers) #4

This is also an issue when you have calculated columns, because you can’t move them ahead of the measures in the results table. The only workaround is hiding the measures and creating a calculated column for the value of each one, a bit of a PITA but it usually works. +1 on using the order as specified in the visualization series options.


(Andrew Rose) #5

Hi all,

Looker support here. Thanks for the feedback - I’ve passed your comments on to our product team.

Thanks,
Andrew


How to change the layering of mixed type visualizations
(Adina Katz) #6

@tnebesar @svickers Thanks for the feedback!

Looks like we can expect to see this feature (the line in the front of the visualization by default) in an upcoming release of Looker. Feel free to check out our release notes for when this feature has been incorporated into the product.

Cheers,
Adina