Any attempt to download dashboard as PDF fails with error

chrome
done
normal_priority
reply
(vfx) #1

Here’s the error from the log.

2019-02-09 16:43:55.559 +0530 [INFO|00850|event:render] :: chromium_render:, type=‘pdf’, target_type=‘wysiwyg_dashboard’, render_success=‘false’, render_message='An attempt was made to access a protected resource: [http://127.0.0.1/6.4.17/U1I2ZABluQc4iQ/7a81733a6efe5fb4c5896c1051116d59/41/8830/page?uri=%2Fpresentation%2Fdashboards%2F10%3Fhas_filters%3Dtrue&ms_epoch=1549710835303&current_user_id=41…]

tried both chromium and chrome - always the same.

0 Likes

(Nicholas Wong) #2

Hey Vik! In order to download your file from looker, press on the gear button on the most right hand side. (Just located beside the run button as shown below)

Click on the “Download…” tab from the drop down and you will get the download options.

If you’re facing an error trying this method, perhaps you might want to share your screen? Was it working before you tried pushing a production/editing the lookerML? If it was, perhaps you might want to off the developer option and try downloading it. Hope this helps! :slight_smile:

0 Likes

(vfx) #3

Hi,

Thanks for your reply. I think you misunderstood the issue.

It’s about downloading a dashboard as PDF. What you are showing is explore as XLS

0 Likes

(Nicholas Wong) #4

Hmmm my bet! This is an uncommon issue. There is however a similar issue posted on the community in November 2018. You can find the post at Email schedule purgatory when Show Filters is turned off. It will be faster if you contact Looker through the live chat to get your problem solved.

1 Like

(Izzy) #5

Nicholas is right— This is an uncommon issue that we’re working on fixing! This usually occurs when you try to access something on the looker server on a different port than what looker is running on, and when you use a loopback address instead of the hostname.

If this sounds like something you’ve set up, then changing your config to use the hostname ie: https://your.looker.com:777/catpicture.jpg instead of https://localhost:777/catpicture.jpg should fix it.

If not, and if your Looker server is running clustered (another reason it’d be calling out for local resources), then I think Nicholas’s advice is again the best route— contact support :slight_smile:

0 Likes

(vfx) #7

Thanks guys,

Checked the hostname and it’s all right (not localhost or 127.0.0.1). I have reported the issue to the support team.

0 Likes

(Rodolphe Quiedeville) #8

Encounter the same problem here under Debian Stretch, hope to see a solution here.

1 Like

(Rodolphe Quiedeville) #9

Thanks to the Looker’s support team I found a solution, our problem was caused by chromium version.
With the last version in Debian Stretch 72.0.3626.96-1~deb9u1 it fail, with an older one 70.0.3538.110-1~deb9u1 it works.

The debug was made using the command chromium --headless --disable-gpu --remote-debugging-port=9222 if it exit(1) you found the reason of your bug.

0 Likes

(vfx) #10

Hi Rodolphe,

Thanks for your contribution. I reverted back to this version but still get the same error.

2019-02-28 16:42:28.543 +0530 [INFO|00852|render] :: Chromium Render Failed: An attempt was made to access a protected resource: [[http://127.0.0.1/6.6.9/U1I2ZABluQc4iQ/7a81733a6efe5fb4c5896c1051116d59/41/15720/](http://127.0.0.1/6.6.9/U1I2ZABluQc4iQ/7a81733a6efe5fb4c5896c1051116d59/41/15720/)…

The support has recognized this as a bug and said they’d fix it in a next release.

1 Like

(vfx) #11

In my case it doesn’t exit with an error. But still doesn’t work.

0 Likes

(vfx) #12

Yay! Works with 6.8.12!

Thanks guys!

0 Likes